9 Replies Latest reply: Aug 31, 2013 1:13 PM by peds48 RSS

Wpa2 passphrase not accepted when trying to connect DCCK


Hi, when first installed I had a satellite internet provider, but since then I have been able to get DSL through Verizon. I have a D-Link DSL-2750B Modem/router combo. My home network works fine, (Computer, phones, I-pads etc) all connected. Got the DCCK and installed it following instructions. When it came time to input my WPA2 passphrase I got a message that it was not accepted. I retried install several times with same result. I even tried connecting the DCCK to another of my receivers, still nothing. I then disconnected everything, thinking that maybe I didn't have some piece of equipment needed and called DTV and they sent out an installer. The installer connected the DCCK the way I had originally connected it and got the same result, passphrase not accepted. Had to sign up for repair coverage @ $7.99 to avoid $50.00 repair bill. My whole home DVR is an HD  HR24/500 and I have two H25/500 HD receivers. I thought I read in an forum that someone with the same problem had figured out that the D-link 2750B was the problem and that they purchase an Actiontec modem/router and that fixed it. I can't find that post. If anyone can help I would appreciate it.