11 Replies Latest reply: Nov 28, 2014 9:36 AM by herbst RSS

Directv2PC crashes immediately on startup


For the past month, Directv2PC has not been working for me. It will crash anywhere between 1 to 5 seconds after the application starts, before it connects with the receiver.

I also have Directv2PC installed on two other computers, and it crashes on them as well. The program has worked on these computers in the past.


I have tried re-installing Directv2PC, restarting the computer, restarting the receiver, and restarting the router, disabling antivirus/firewall, but have had no luck.


I ran the system test on the receiver and no network issues were found, and I am able to access the internet from my receiver. I don't recall having changed any network settings on my router.


If I disconnect the ethernet cable on the receiver and try to start the application, it still crashes. But, if I just disconnect the ethernet cable on my PC, the application does not crash. This makes me think that the problem isn't with my computer but either the router or receiver.


Does anyone have any ideas?




Here's some more information:


OS: Windows 7 x64

CPU: Intel i5 2500k

Graphics: HD 6950 2GB


Receiver model: HR22/100

SW build: 0x803, 3/25


Problem signature:

  Problem Event Name: APPCRASH

  Application Name: DIRECTV2PC(TM).exe

  Application Version:

  Application Timestamp: 4a23d8d0

  Fault Module Name: CLNetMediaCDS.dll

  Fault Module Version:

  Fault Module Timestamp: 4a3205fb

  Exception Code: c0000005

  Exception Offset: 0000334e

  OS Version: 6.1.7601.

  Locale ID: 1033

  Additional Information 1: 0a9e

  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

  Additional Information 3: 0a9e

  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

  • Re: Directv2PC crashes immediately on startup

    On your computer right click the remote and select "personalize".  Set the theme to "Windows Basic" then try starting the Directv2PC software. 

  • Re: Directv2PC crashes immediately on startup

    I have this exact problem.  I previously had directv2pc running on a desktop and a laptop.  I occasionally used them and never had an issue.  last time I accessed the application was probably late Feb.  I noticed that neither client works now on both of my machines.  I have scoured trying to find a resolution to this, I updated display drivers, I updated flash, I turned off my router firewall (which was previously enabled when it did work), I made sure to set my Windows 7 display to Basic and as a last resort even uninstalled the client and reinstalled on my desktop but it made no difference either way.  I get the exact same application crash where it complains about CLNetMediaCDS.dll just like it does on your error.  Have you or anyone found a solution to this?  Being able to access my DVR recordings from my PC was a huge benefit. 

    • Re: Directv2PC crashes immediately on startup

      No, it's still not working for me. I have a feeling the latest receiver software update broke this (version 0x803 on 3/25). I had 3 separate PCs with the Directv2PC software working, and then they all stopped working around this date. No changes were made to these PCs or my router. I wish there was a way to downgrade the receiver S/W version to see if this is indeed the problem.


      What receiver model and S/W version do you have?


      Does anyone else have receiver software version 0x803 installed and have Directv2PC working?

  • Re: Directv2PC crashes immediately on startup

    I am running mine on my notebook Win7 and for the past year it worked fine. Then about a month ago if my computer shuts down, when I tried to open I am getting unable to open and crashes. If I uninstall and reinstall it it works untill the computer  is shut down, it gets old redownloading programs off of your list. I called support and they are no help what so ever.

  • Re: Directv2PC crashes immediately on startup

    I have the same issue as original poster. The program Directv2pc immediately crashes on startup. This program has worked well for me for over 4 or 5 years. I am running windows 7 on both pc's. I have uninstalled and reinstalled and updated.


    I have tried to remove the security update that previous poster suggested as well.


    I have tried to run as administrator and also in windows basic mode.


    This has all happened over the last 4-6 months.


    Any suggestions appreciated.


    I have run the advisor and it is not "all green" but it is not changed at all from the original findings.