8 Replies Latest reply: Aug 29, 2013 10:19 AM by dbaxter RSS

GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware

dbaxter

I consider myself a pretty technical person when it comes to networking, but I'm not sure what I'm missing here. I can't get the OOH feature working with my new GenieGo.

 

Here's what I've tried:

1.  I'm able to see both of my Whole Home networked HR22 DVR's and view content and download content on my local network, so I know my GenieGo is working on my LAN. and I'm only on one network 192.168.1.*

All 3 blue lights are lit blue and solid on the GenieGo.

 

2.  I tried to FIRST do the automated OOH setup, and it found my router on its Step1, and tried to let GenieGo do its thing. On the Step2 of auto configuration, I get a javascript error popup saying on Line:1 - Char:1092  -  Error:'RAINIER' is undefined - Code:0 - URL:http://192.168.1.1/ui/static/js/shims.js    I then select Yes to continue running scripts.

 

After pressing YES, it shows that it was unable to configure router for OOH, and router it found was also the wrong model (Cisco AG241(Linksys Firmware)), so I clicked CHANGE ROUTER button and selected Linksys EA4500 from the list. I had previously also changed the password on my router too, but wasn't sure which username to try in GenieGo config (I tried both username/password combinations of my login for the Smart WiFi web site login and admin/<routerPasswordHere>, but neither would get the OOH working).

 

3.  After the Auto configuration failed, I decided to try the manual port forward option. So I set the ports for the OOH for the GenieGo to 8085 & 8086 (I had also forwarded those in my Router as both UDP and TCP, with the GenieGo's IPV4 address set as a DHCP reserved IP address), since I have another server running on 8082. I set up port forwarding on my Linksys EA4500 router configured with their website/Smart Wifi instead of directly to 192.168.1.1, this may be one of the problems???, does GenieGo not support that type of router software?

After trying to use "Manual Port Setup" it fails in a loop of me confirming the ports, and clicking the "test out of home access" button. Will not go any further and always fails after that.

 

4.  I have tried this with Windows 7 Pro 64bit, Windows 8 Pro with Media Center 64bit, and also tried to get it working on my Iphone 4s GenieGo app. All of them fail to get this working.

 

My Comcast Xfinity Cable modem(SMCD3GNV) is set to bridged mode so my router is the only "DHCP router" in the loop, and I have other servers running just fine on my network to the outside world.

I have it connected as:   GenieGo -> Linksys EA4500 Router -> SMC Cable Modem -> WAN/Internet

 

I'm not sure what else I need to try, please help. If you need more information on my setup let me know.

  • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware

    In my Linksys router E2000 I only have DCP checked. Also you may need to setup port forwarding in your modem.

  • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware
    nuspieds

    I have the E4200 and for my port forwarding, I selected TCP only.

  • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware
    peds48

    Whenever two routers are involved the GenieGO can only setup the first one.  The second router has to be setup manually for port forwarding if it’s not already setup in bridge mode.

     

    you can confirm if two routers are present by using the trace route utility.  On Windows PCs, you have to go to a command prompt (in the search files and programs window at the bottom left corner of the menu enter CMD) and then enter tracert www.directv.com.  If you are running windows 7, you first must enter cd \windows\system32 before entering the tracert command.  iOS and Android devices also have this command but it’s best to use a PC connected to the same router the GenieGO or broadband DECA is on since the wireless devices may be connecting to the 2nd router’s wifi.

     

    This command shows the router hops it takes to get from the PC to the Internet.  If there’s a 2ndrouter in the path it will show the 2nd internal IP address as the 2nd hop.  In other words you may see 192.168.1.1 as the first hop and 192.168.0.1 (or 10.0.0.1/172.31.0.1; any internal private IP address) for the 2nd hop.  192.168.1.1 and 192.168.0.1 are valid for two routers because they are on two different subnets.

     

    So if you see a 2nd hop using an internal IP address that’s the router they need to login to and setup manual port forwarding (Netgear is documented on the webpage support tool).  However instead of using the GenieGO’s IP address on this 2nd router, you have to use the WAN address assigned to the first router.  That WAN address will actually be a DHCP IP assigned by the 2nd router, so if the 2nd router is using 192.168.0.1 the WAN address on the first router could be anything in the 192.168.0.x range.

     

    I believe the GenieGO will already take care of the port mapping on the first router without setting it up manually and you need to get the WAN IP from that same router.  So first have  login to the Linksys and delete all manual port mappings for the GenieGO.  You can leave the DHCP IP address reservation for the GenieGO as is.  Then go to the status screen and record the Internet IP address from the bottom half of the screen; this is the IP that will be used to setup forwarding on the 2nd router instead of the GenieGO’s IP address.

     

    Once you have done that you can logout of the Linksys and then login to the Netgear using the same IP address shown as the 2nd hop.  Then just follow the manual config process on the webpage for the Netgear (use the same ports of 8082/8083).  

     

    Once you complete this, reboot the GenieGO and exit and restart the client.  After the GenieGO lights are all blue / flashing blue, wait another 3-4 minutes and then go to the client setup screen, scroll down to the bottom and see if OHS testing passes.

    • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware
      lhorne

      I am having the same issue as the original poster, I tried to follow your instructions with tracert command but do not see the information you are talking about. It does not show any IP addresses just "options"

       

      Can you please walk through the process step by step for me in more detail?

      • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware

        Below is what you should see. Make sure you are at the command prompt.

         

        Microsoft Windows [Version 6.1.7601]
        Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

        C:\> tracert www.directv.com        <----- Make sure and include www.directv.com   

        Tracing route to e6691.g.akamaiedge.net [23.9.85.9]
        over a maximum of 30 hops:

          1     1 ms    17 ms    <1 ms  MYWIFI [xxx.xxx.x.x]
          2    17 ms    29 ms     9 ms  modem.Home [xxx.xxx.x.x]     <----------- This one
          3    20 ms    25 ms    38 ms  hlrn-dsl-gw08.hlrn.qwest.net [xxx.xxx.xxxx]
          4    20 ms    36 ms    29 ms  hlrn-agw1.inet.qwest.net [xx.xx.xx.xx]
          5    90 ms    33 ms    28 ms  hlr-edge-09.inet.qwest.net [xx.xx.xx.xx]
          6    20 ms    31 ms    24 ms  a23-9-85-9.deploy.static.akamaitechnologies.com
        [23.9.85.9]

        Trace complete.

        C:\>

    • Re: GenieGo OOH not working with Linksys EA4500 with Smart WiFi firmware
      dbaxter

      Wow, what a convoluted canned answer, but helped me figure it out nonetheless.

       

      I was finally able to figure this out. It seems that my Comcast SMC cable modem/router was flipped somehow out of "bridge mode", and I did not have the new ports 8085 and 8086 that I chose, forwarded on the SMC router. I put the forwarding into the SMC router to forward to a static IP(I had to set this up static for the time being) address of my Linksys EA4500 router, which in turn had my existing forwarding rules to go to the GenieGo's IP. Now it works. I still have to call Comcast and find out how to get the SMC router back into bridge mode(I don't like double NATting confusing for me and not sure it is reliable anyway), that way I don't have to do forwarding on the SMC router, simply on my Linksys EA4500 router like I had been doing for the past 3 years. That's why it is confusing why this suddenly got kicked out of bridge mode.

       

      Moral of the story, if you have this SMC router(which won't allow you to do the bridge mode as a consumer btw) and Comcast, you have to call them up to put the SMC into bridge mode if you aren't using it for anything more than a modem, then you can simply set a single point of forwarding rules on your internal Linksys EA4500.

       

      Thanks to everyone who tried to help me with suggestions, it helped find the true root of my problem, and I wanted to share my solution to help others.