Welcome to the DIRECTV Community Forums - connect with users, ask questions, and find answers!

J

2 Messages

Friday, September 15th, 2023 9:29 PM

Gemini Air dropping connection

I recently hooked up the device in my bedroom TV hung on the wall. I constantly lose internet connection on the device. I have a very strong connection in bedroom (my router is in living room on other side of the wall). Could being behind a large tv cause the issue? I had a Roku TV previously in same spot without issue. I don't have any hiccups when it is connected like a weak signal. I thought of buying an HDMI extension cable

Community Support

 • 

20.5K Messages

10 months ago

Thank you for reaching out. We want you to use your Gemini Air device with no issues. Following these steps, you can check the internet connection stability status :

 

Press Home on your Gemini remote.
1. Choose Settings, then Help.
2. Select Troubleshooting, then Run Network Diagnostics.
3. Refer to LED Statuses:

 

Off = No power
Solid Red = Insufficient power
White = ON and connected with a strong signal
Yellow = On and connected with weak signal
Flashing Red = No router or internet connection, searching for connection
Red and Blue transition during the boot process = red indicates powering up and doing power verification, and blue indicates passing the power check and continuing to boot.


For additional troubleshooting, please visit https://www.directv.com/support/internet/article/000095432

 

Let's meet in private to check your internet status results. Jeison, DIRECTV Community Specialist

2 Messages

10 months ago

I tried to run the troubleshooting and I get an error that says we had trouble your Network Diagnostics.Please try again later

Community Support

 • 

20.5K Messages

10 months ago

Thank you for confirming that, Let's continue on a private message. Jeison, DIRECTV Community Specialist

1 Message

3 months ago

I have had Stream fo about one year. It's installed on three TVs with Gemeni Air and we are using fire sticks on two others with no connectivity issues.  The three using Gemini Air costantly drop the internet signal. All of the Gemeni Airs have been replaced and the problem persists. I have had numerous conversation with Direct TV customer service and they advise the poblem is with my internet provider. They have been out to check the systen and do not find any issues on their end. Where do I go from here. ?

3 months ago

My system has the same problem.  I have 3 Gemini Air Devices installed last month (March 2024).  Randomly, and typically occuring every other day, I turn on the TV and I get a blank screen. 

I have found that if I push many different buttons on the remote as possible, I eventually get to a screen that states "No Internet Connection" with 4 options at the I select Go to Settings.  I then use the down arrow key to select System and press OK on the remote.  On the right side it shows Settings, General Settings, and Network & Internet (my internet name is on the next line down).  If I press OK, it shows that the Wi-Fi toggle is ON (in Blue), and that my Available Networks below; below my network name is "No Internet".  If I toggle the Wi-Fi Off and then ON, my network name now shows "Connected" and a blue banner shows up on Network Connected successfully".

The system works as it should until it acts up again over the next couple of days.  I contacted DirecTV help, they had me perform a master reset (still the same issue) and then I talked to someone today and they said that the only option is to replace all of them and that "hopefully" the problem is solved...  

How do I program the dongle to keep memory of my internet connection?

Community Support

 • 

20.5K Messages

3 months ago

I appreciate you sharing your experience, and we hope this will get resolved once the replacement is successfully activated, r/FrustratedonWhidbey. Please get in touch with your internet provider for assistance in programming the dongle to keep your internet connection memory. Veilka, DIRECTV Community Specialist

1 Message

2 months ago

I have the exact same issue and solution when it acts up.  It has worked flawlessly for six months but the past few weeks has been a daily or every other day problem.  

did the new Gemini’s solve the problem?

zac

20 Messages

1 month ago

I am having the same problem that many are posting about. I have 3 TVs in my house currently on DirecTV via Gemini device. Two of them work fine, but on has the "No Internet Connection" problem. The failure mode is that if the TV is off for 4 hours or so, or overnight, when I turn it on I get a blank screen and eventually the message about No Internet Connection. The LED on the device is white, indicating a good WiFi connection and if I push enough buttons to get it to respond and get to the Home screen and get to the network settings menu I can see that the WiFi connection shows excellent. The only way to get the Gemini to work is to Restart it with the remote/menu system, or to power cycle the Gemini device. I have a theory that I am in the process of validating though. The problem TV is an old Panasonic Plasma TV and is my main TV in my home theater. It is surrounded by electronic components and I fear the old TV is generating interference when it is on that prevents the Gemini from establishing a valid WiFi connection to the internet. I know it is not the Gemini device per se because I swapped it with a Gemini from a working TV and the same thing happens with the known good Gemini. When all is working, if I turn the TV off with the Gemini remote and turn it back on within an hour or so, it works fine. I have done a test though where I use the Gemini remote to only turn the Gemini on (by blocking the IR to the TV) wait a minute and then turn on the TV, everything works. My this seems to indicate to me that if the TV isn't on and generating interfereice, the Gemini will successfully establish a valid WiFi connection to the internet. My solution that I am going to try is I am getting a HDMI extender cable so I can relocate the Gemini away from the TV and see if this works. I am optimistic that this will work ... waiting for the cable to arrive. 

I hope this helps someone else. It seems that the Gemini requires a very good WiFi signal with no interference to work properly. I love it when it works though, which is why I am working so hard to make it work.

20 Messages

1 month ago

I have an update to my previous post regarding the problems I am having with using the DirecTV Gemini device in my environment and getting the “No Internet Connection” message. Placing the Gemini device further away from my TV with a HDMI extender cable did NOT solve the problem. Through further testing and thought here are my findings. The problem only happens when both the TV and Gemini device have been powered off for quite a while (4 hours or more). The problem also ONLY happens if my TV is not set to the HDMI port that the Gemini is connected to when it is powered off. In this situation when I use the Gemini remote to turn on the Gemini and TV, both are powered on and at that time the TV switches HDMI ports to the Gemini device. This is where the failure happens. I get a blank screen and eventually get the No Internet Connection message that is only cleared by “Restarting” the Gemini with the remote, or unplugging the power to the Gemini device and plugging it back in. If the TV is already set to the Gemini HDMI port when it is powered off, the problem doesn’t happen the next time I power it on. It seems to be some sort of HDMI power on handshaking/switching/timing bug. Also, if I use the Gemini remote to first only power on the Gemini (by blocking the IR transmitter) and waiting 10 seconds or so and then pressing the ON button on the remote again with the IR transmitter not blocked, the TV will then power on, switch ports successfully and everything works fine.

The reason I am putting so much effort into this is that I have been using U-Verse for a long time and want to move away from its limitations. The problem is that while U-Verse has its quirks, it has always been very reliable (except until recently) and the other user in my house (wife, no gender implications implied or intended) will be very unhappy if DirecTV isn’t bullet proof reliable.  From searching the forums I also know that many other people are having the No Internet Connection issue in various forms and hopefully this information helps them develop a workaround for the problem that helps them.

The reason I am not having any problems with the other TVs in the house is that they only have DirecTV connected to their HDMI inputs so no switching is ever needed, hence problem avoided. It is interesting to observe how HDMI connections control devices and the results I see. If I am watching U-Verse and then use the TV remote to manually switch to the Gemini HDMI port, the switching process will automatically power on the Gemini as it switches and everything works in that case as well. The problem only happens with both are powered off and are powered on at the same time AND a HDMI switch must happen. This particular TV is also a quite old (2007) Panasonic Plasma TV and as such is probably using an older version of HDMI (probably 1.1) which may contribute to the problem as well.

I don’t know if DirecTV monitors this forum, but if they do they might find this information helpful in solving the problem that from what I can see, many users are having in one form or another.  From my research I have also noted that for some users this problem only recently started happening. I understand that the Gemini devices have their firmware periodically updated automatically if needed and perhaps some sort of firmware bug has been introduced as a part of this. I can’t help but think if this information gets to the proper level of technical expertise within DirecTV they can’t work to solve this bug and increase the level of satisfaction for all users.

If I didn’t find the features of DirecTV Stream so compelling I would have boxed all the equipment up days ago and cancelled my account. I am fortunate that I have identified a viable workaround so am continuing my evaluation of DirecTV and hopefully will cut off U-Verse soon.

20 Messages

1 month ago

Here's another failure mode if anyone is paying attention. This is in addition to what I have outlined previously. I discovered a situation where when I turned off the Gemini and TV while watching the Netflix App, the next time I turned on the TV and Gemini I got the blank screen and eventually "No Internet Connection" message. This is on a TV that I am not having the HDMI switching problem, because I don't switch inputs on this TV. Anyway, I had to Restart the Gemini with the remote to get everything working again. 

ACE - New Member

 • 

3.2K Messages

1 month ago

easy solution...exit the apps before you turn off your device

20 Messages

1 month ago

Absolutely correct. I tend to call that a workaround, but yes, that is the solution for now!

ACE - New Member

 • 

3.2K Messages

1 month ago

takes a couple of seconds 

20 Messages

27 days ago

I want to post an update with my DirecTV Genesis Air connectivity challenges that I have posted about previously. I really love the features of DirecTV which is why I am fighting so hard to make this work. To recap, I have been getting the dreaded No Internet Connection message when powering up various TV/DirecTV combinations around my house. As documented previously I have tested many things and found some workarounds to minimize the issues. However, I truly think I have found the solution now.

The WiFi network I was using when I began all of this was a Linksys Velop Mesh system. It was a first generation system that I bought 6.5 years ago. It has been great with outstanding coverage and performance and all of my devices have been working fine for all this time. It just does its magic and works. I realized that perhaps WiFi has come a long way in 6.5 years, so over the weekend I bought a current Linksys Velop Mesh system (Pro 6E). I replaced my old mesh environment with the new one and it appears ALL of my connection issues with the DirecTV Genesis system have been resolved. While with the old system the signal strength was strong all over the house, there is apparently some “incompatibility” with the old protocols on the old system. Not only that, but my overall WiFi performance across all devices has increased dramatically, which surprised me. The marketing hype always touts this, but it’s not hype in my environment. I don’t know exactly how many generations have transpired between my original 1st Generation system to what’s around now (maybe 6?), but it just works better and is obviously seems to have solved my issues. This may seem drastic for many of you, but like I mentioned I wanted this new DirecTV platform to work for me, and it now does. Hopefully this might help others.

21 Messages

13 days ago

I am having the exact same issue with my Gemini system.  I installed 2 Gemini devices in my Mom's apartment at the first of June and they have worked fine till about a week ago.  Overnight both of them go to sleep and she gets the "no internet connection" screen or nothing but a blank screen.  I have done the factory resets 2x, no help.  I can always get system to run properly by either restarting the device or doing a power cycle (unplug and replug) the USB c port.  I'm going to try a mesh style router next! Hard to believe this might fix it, as the device is only 8 feet from AT&T router!


NEED HELP?

New to the Community? Visit the Community How-To and Guidelines to get started.